1

QoS (traffic – policing) ile bandwith yönetimi

Merhaba Arkadaşlar ,

QoS in önemi tartışılamaz elbette. QoS ile alakalı bilinmesi gereken iki teknoloji vardır ;

 

1-) Traffic Shaping

2-) Trafic Policing

 

Biz traffic policing üzerinde bir örnek yapacağız.

 

20 Mb hattınızın olduğunu düşünün . Bu ağınız 3 adet vlanınız bulunmakta ; VLANA , VLANB , VLANC .

BU 3 vlandan VLANA ya 5 Mb ayırmak istersen yani , VLANB ve VLANC en fazla 15 Mb kullanabilsin diyorsak ;

 

qos

 

 

Konfigürasyonumuzu  Routerın local bacağını baz alarak yapıyorum. İstenilirse Wan portu baz alınarak da yapılabilir.

 

VLANA nın Networkü 172.18.30.0/24 olsun. Bütün Local Networkte 172.18.0.0/16 olsun.

 

Router(config)#mls qos                      // QoS u etkinleştirdim.

 

Router(config)#ip access-list extended qos_lab1
permit ip 172.18.30.0 0.0.0.255 any                   // Burada VLANA nın dışarıya giden paketlerini yakalıyoruz.

 

Router(config)#ip access-list extended qos_lab2                                          //  Burada VLANA hariç bütün networkü yakalıyoruz.

deny   ip 172.18.30.0 0.0.0.255 any
permit ip 172.18.0.0 0.0.255.255 any

 

Router(config)#class-map match-all police-san1
match access-group name qos_lab1

Router(config)#class-map match-all police-san2
match access-group name qos_lab2
Router(config)#policy-map police-san-replication1
class police-san2
police cir 15000000      // Burada VLANB ve VLANC nin (yani VLANA hariç  bütün networkün en fazla 15 MB kullanabilmesini söylüyoruz. )
exceed-action drop     // 15 MB i geçtiği an paketin drop olmasını söylüyoruz.

class police-san1
police cir 5000000  // Burada VLANA ya 5mb ayırdık.  VLANA için ayrı yaptık çünkü VLANA nın kullandığı bandwidthi izleyebilelim :)
exceed-action transmit  // Transmit yazdık çünkü 5mb i geçerse sadece bilelim. paket drop olmasın, izleyelim ne kadar aşıyor.

class class-default

 

Şimdi bu policyi interface’e bind edelim ;

Router(config)# interface GigabitEthernet1/13
bandwidth 20000 // bandwidthi 20 Mb olarak ayarladık. Eğer QoS yapılacaksa Bu yapılmalı, tavsiye edilir :)
load-interval 30   // Defaultta 300 saniyedir ve bu performansı kötü yönde etkileyebiliyor.
service-policy input police-san-replication1  // İnterface e giren trafiğe QoS uygula dedik (Kullanıcılar için Download demek bu )

 

 

Şimdi Trafiği izleyelim :

 

Router(config)#show policy-map interface gigabitEthernet 1/13
GigabitEthernet1/13

Service-policy input: police-san-replication1

class-map: police-san2 (match-all)
Match: access-group name qos_lab2
police :
15000000 bps 468750 limit 468750 extended limit                                     // Burada ayrılan Bandwith miktarını görüyoruz.
Earl in slot 1 :
2382281 bytes
30 second offered rate 310376 bps
aggregate-forwarded 2382281 bytes action: transmit                             // Burada   geçen trafiği görüyoruz ki bu 15 mb in altında
exceeded 0 bytes action: drop                                                                           // Burada drop edilen paket miktarını görüyoruz.
aggregate-forward 351232 bps exceed 0 bps

class-map: police-san1 (match-all)
Match: access-group name qos_lab1
police :
5000000 bps 156250 limit 156250 extended limit
Earl in slot 1 :
0 bytes
30 second offered rate 0 bps
aggregate-forwarded 0 bytes action: transmit                       //  0 olması normal , şu anda trafik yok çünkü, ama test edildi. Konfig çalışıyor.
exceeded 0 bytes action: transmit
aggregate-forward 0 bps exceed 0 bps

Class-map: class-default (match-any)
0 packets, 0 bytes
30 second offered rate 0000 bps, drop rate 0000 bps
Match: any
0 packets, 0 bytes
30 second rate 0 bps

 

Evet Download ı hallettik , peki Upload ne olacak ? Aynı şekilde dışarıdan gelen paketleri ACL ile yakalayıp QoS uygulayacağız.

ip access-list extended qos_lab11
permit ip any 172.18.30.0 0.0.0.255                 // Dışarıdan VLANA ya gelen paketleri yakalıyoruz.

ip access-list extended qos_lab22
deny ip any 172.18.30.0 0.0.0.255
permit ip any 172.18.0.0 0.0.255.255

class-map match-all police-san11
match access-group name qos_lab11

class-map match-all police-san22
match access-group name qos_lab22

 

policy-map police-san-replication11
class police-san22
police cir 15000000
exceed-action drop

class police-san11
police cir 5000000
exceed-action transmit

class class-default

 

Şimdi bu policyi interface’e bind edelim ;

Router(config)# interface GigabitEthernet1/13
service-policy out police-san-replication11 // İnterface den çıkan trafiğe QoS uygula dedik (Kullanıcılar için upload demek bu )

Umarım faydası olur :)

 

 

 

 

 

 

 

 

 

Bu yazıyı paylaş..Share on LinkedInShare on Google+Share on FacebookTweet about this on Twitter

Numan KARAKAŞ

One Comment

Bir Cevap Yazın

E-posta hesabınız yayınlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir