0

OSPF Anlatımı

Merhaba Arkadaşlar,

Ospf ‘i anlatmak için aşağıdaki topolojiyi kullanacağım.
ospf

Evet görüldüğü gibi OSPF protokolünde arealar vardır.Neden mi? şöyle bir topoloji düşün ki içinde 1000 tane router var.Bu sisteme yeni bir router ekleniyor.Bu yeni eklenen router ben geldim demek için broadcast yollayacağı için çok fazla trafik olur.Bu tür durumların networü down etmesi oldukça güçlü bir ihtimal.İşte bu tür durumları ortadan kaldırmak için network arealara ayrılır.Yeni eklenen router sadece kendi areasına uptadate paketlerini yollar.Ama ağ kuracağınız eğer küçük bir işletme ise o zaman area 0(backbone) yeterli olacaktır. Ayrıca ospf de her zaman bir hükümdarlık vardır.Yani hem arealar arasında hem bir area içindeki routerlar arasında bir başkan (hükümdar da diyebiliriz :)buna ) vardır.Arealar arasındakı başkan herzaman area 0 dır.Area 0 a bundan dolayı backbone area denir. pekiii bu başkanlar neden seçiliyor? arealar arasında iletişim area 0 (başkan) üzerinden sağlanıyor.Aynı durum bir area içindeki iletişim de geçerli .Aynı area içindeki routerlar DR(başkan) router üzerinden birbirleriyle haberleşirler.Umarım anlaşılmıştır

Eveeet şimdi gelelim başkan routerın nasıl şeçildiğinde çok basit :)

Routerda loopback interface yoksa aktif olan interfacelerden en büyük IP değerine sahip olanın IPsi Router id olur.Ama eğer loopback ip girdiysen, routerda tanımlanmış en büyük loopback ip adresi routerda id olarak seçilir.Son olarak en büyük router Idli router DR, ikincisi BDR seçilir.

Topolojimize gelirsek;

R1 için :

interface Loopback0
ip address 1.1.1.1 255.255.255.255

interface Ethernet1/2
ip address 123.123.123.1 255.255.255.0
half-duplex

router ospf 1
log-adjacency-changes
network 123.123.123.0 0.0.0.255 area 0

Yukarda gördüğümüz gibi R1 e loopback adresi girilmiştir .Bu durumda R1 in İD si 1.1.1.1 dir.

R2 için:

interface Loopback0
ip address 2.2.2.2 255.255.255.255

interface Ethernet0/0
ip address 123.123.123.2 255.255.255.0
half-duplex
!
interface Ethernet0/1
ip address 35.35.35.2 255.255.255.0
half-duplex
!
interface Ethernet0/2
ip address 24.24.24.2 255.255.255.0
half-duplex

router ospf 1
log-adjacency-changes
network 24.24.24.0 0.0.0.255 area 0
network 35.35.35.0 0.0.0.255 area 0
network 123.123.123.0 0.0.0.255 area 0
!

R3 için;

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Ethernet0/0
ip address 123.123.123.3 255.255.255.0
half-duplex
!
interface Ethernet0/1
ip address 35.35.5.3 255.255.255.0
half-duplex
!

router ospf 1
log-adjacency-changes
network 35.35.5.0 0.0.0.255 area 35
network 123.123.123.0 0.0.0.255 area 0
!

R4 :

interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Ethernet0/0
ip address 24.24.24.4 255.255.255.0
half-duplex
!
interface Ethernet0/1
ip address 24.24.4.4 255.255.255.0
half-duplex
!

router ospf 1
log-adjacency-changes
network 24.24.4.0 0.0.0.255 area 24
network 24.24.24.0 0.0.0.255 area 0
!

R5 için;

interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface Ethernet0/0
ip address 35.35.5.5 255.255.255.0
half-duplex
!
interface Ethernet0/1
ip address 35.35.35.5 255.255.255.0
half-duplex
!

router ospf 1
log-adjacency-changes
network 35.35.5.0 0.0.0.255 area 35
network 35.35.35.0 0.0.0.255 area 0
!

R6 için :

interface Loopback0
ip address 6.6.6.6 255.255.255.255
!
interface Ethernet0/0
ip address 24.24.4.6 255.255.255.0
half-duplex

eveeeeet şimdi muhtemelen soruyorsunuzdur ;

yukarıda ospf yaparken interfaceleri hangi area ile eşleştireceğimize nasıl karar vereceğiz ?

her areanın area0 ile bağlantı noktası görevini yapan bir router vardır .Bu routerlera ABR (Area Border Router) denir.Örneğimiz üzerinden gidecek olursak ;

area 35 için ABR olarak R5′i seçtim.
area 24 için ABR olarak R4′ü seçtim.

şimdi ospf arayüzünde areayı nasıl belirliyoruz.Öncelikle şunu belirtmek istiyorum aynı link(kablo,hat) üzerinde arealar aynı olmak zorundadır. mesala R5 ile R2 arasında kablo aynı area ile eşleştirilmelidir.Aynı şekilde R4 ile R2 arasındaki kablo aynı area ile eşleştirilmelidir. Daha iyi anlaşılması için aşağıda üç senaryo yaptım.

mesala R5 ile R2 arasında;

Doğru:

R5 de ; network 35.35.35.0 0.0.0.255 area 0
R2 de; network 35.35.35.0 0.0.0.255 area 0

Doğru:

R5 de ; network 35.35.35.0 0.0.0.255 area 35
R2 de; network 35.35.35.0 0.0.0.255 area 35

Yanlış:

R5 de ; network 35.35.35.0 0.0.0.255 area 35
R2 de; network 35.35.35.0 0.0.0.255 area 0

Yanlış:

R5 de ; network 35.35.35.0 0.0.0.255 area 0
R2 de; network 35.35.35.0 0.0.0.255 area 35

Umarım faydalı olmuştur.Evet son olarak networkün çalıştığını doğrulayalım

R6#ping 123.123.123.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 123.123.123.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/108/144 ms

R6#ping 35.35.5.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 35.35.5.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/88/120 ms

haaa unutmadan mesala bakalım area 24 de DR hangi router .Loopback adresi en büyük R6 olduğu için DR nin R6 olması gerekiyor.BDR nin ise R4 olması gerkiyor .

DOĞRULAYIM!

R6#show ip ospf interface
Ethernet0/1 is up, line protocol is up
Internet Address 192.168.56.2/24, Area 24
Process ID 1, Router ID 6.6.6.6, Network Type BROADCAST, Cost: 10
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 6.6.6.6, Interface address 192.168.56.2
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

R4#show ip ospf interface
Ethernet0/0 is up, line protocol is up
Internet Address 24.24.24.4/24, Area 0
Process ID 1, Router ID 4.4.4.4, Network Type BROADCAST, Cost: 10
Transmit Delay is 1 sec, State BDR, Priority 1
Backup Designated router (ID) 4.4.4.4, Interface address 24.24.24.4

İyi çalışmalar.

Bu yazıyı paylaş..Share on LinkedInShare on Google+Share on FacebookTweet about this on Twitter

Numan KARAKAŞ

Bir Cevap Yazın

E-posta hesabınız yayınlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir